Список форумов Kage Project Kage Project
 
  РегистрацияРегистрация  ВходВход
  Архив субтитровАрхив субтитров  ПоискПоиск  ЧаВоЧаВо  ПользователиПользователи
 Войти и проверить личные сообщенияВойти и проверить личные сообщения

VLC - анимация субтитров

 
Начать новую тему   Ответить на тему    Список форумов Kage Project -> Техническая поддержка
Предыдущая тема :: Следующая тема 
Автор Сообщение
Horodep

Переводы



Зарегистрирован: 14.10.2013
Сообщения: 164
СообщениеДобавлено: Пн Окт 20, 2014 2:31 am   Заголовок сообщения: VLC - анимация субтитров Ответить с цитатой

Доброго времени суток. Возникла такая проблема.
Начну с предыстории, чтобы была понятная моя последовательность действий.
В компе стояла GTX 760 и все было прекрасно. Около месяца назад нвидиа обновила дрова до 344 и тут понеслось.
Комп перестал воспроизводить 10bit видео. (пользуюсь MPC) Пробовал и так и сяк. Не идет. Саппорт нвидии тоже ничего толком не дал. Итог - я откатился на рабочую версию драйвера и отменил обновления. Все работало.

А потом я обновил карту до GTX 970. А к ней подходят только 344 и выше. И ни одна из версий драйвера не позволяет воспроизводить 10bit видео.
Я направился искать другие проигрыватели - да, тот же VLC внезапно работает. Но есть проблема. Анимация субтитров с настройками по умолчанию хромает. Субтитры сдвигаются скачками примерно 10 раз в секунду.

Вопрос - как этого избежать. Как настроить нормальную анимацию субтитров в том же VLC.
К началу
Посмотреть профиль Отправить личное сообщение Добавить в игнор-лист
kievbear



Зарегистрирован: 18.08.2010
Сообщения: 813
Откуда: Киев, Украина
СообщениеДобавлено: Пн Окт 20, 2014 3:07 am   Ответить с цитатой

Простите, но причем тут версия драйвера видеокарты ? Для воспроизведения 10 bit видео Вам нужны только соответствующие кодеки и только. Переустановка последней версии K-lite или CCCP Вам однозначно поможет.
Что касается VLC - то он вещь сама в себе. и видео и субтитровый кодеки там самописные, и далеко не факт, что они умеют во все расширения стандарта ASS. т.е. анимации (не знаю что конкретно вы имеете в виду под этим термином) может и не быть, просто потому, что "не реализованно в данной версии".
для более детального разбора - дайте ссылки на равку и соответствующие ей субтитры, в которых "анимация не работает". А так же примерно опишите - что именно "не работает".
К началу
Посмотреть профиль Отправить личное сообщение Добавить в игнор-лист Номер ICQ
Meo

Переводы



Зарегистрирован: 18.08.2005
Сообщения: 259
Откуда: Украина, Кременчуг
СообщениеДобавлено: Пн Окт 20, 2014 10:41 am   Ответить с цитатой

госьпади... А кто-то ещё пользуется кодекпаками?
MPC-HC ОТСЮДА изкоробки играет ВСЁ, в том числе 10битное, с аппаратным ускорением. + бонусом удобная коррекция тайминга сабов налету. Без загаживания системы дополнительными кодеками, нужными лишь только если занимаетесь кодированием видео.
К началу
Посмотреть профиль Отправить личное сообщение Добавить в игнор-лист Посетить сайт автора Номер ICQ
Horodep

Переводы



Зарегистрирован: 14.10.2013
Сообщения: 164
СообщениеДобавлено: Пн Окт 20, 2014 22:26 pm   Ответить с цитатой

kievbear
я тоже крайне удивился. но ни переустановка k-lite, ни ссср не помогли.

Meo
спасибо за ссылку. заработало.
К началу
Посмотреть профиль Отправить личное сообщение Добавить в игнор-лист
vivan
Гость




СообщениеДобавлено: Ср Окт 22, 2014 0:08 am   Ответить с цитатой

kievbear:
Простите, но причем тут версия драйвера видеокарты ?
Изначальная проблема, кстати, вызвана как раз таки ошибкой в драйвере нвидии -> http://forum.doom9.org/showthread.php?p=1694190#post1694190
Решается переходом на madVR, либо отключением P010 в настройках декодера.
Ну либо ночной сборкой mpc-hc, да, где прикрутили временный костыль.
К началу
Horodep

Переводы



Зарегистрирован: 14.10.2013
Сообщения: 164
СообщениеДобавлено: Ср Окт 22, 2014 1:25 am   Ответить с цитатой

vivan:
kievbear:
Простите, но причем тут версия драйвера видеокарты ?
Изначальная проблема, кстати, вызвана как раз таки ошибкой в драйвере нвидии -> http://forum.doom9.org/showthread.php?p=1694190#post1694190
Решается переходом на madVR, либо отключением P010 в настройках декодера.

Спасибо вам громадное! Отключил P010 - все заработало.
К началу
Посмотреть профиль Отправить личное сообщение Добавить в игнор-лист
Показать сообщения:   
Начать новую тему   Ответить на тему    Список форумов Kage Project -> Техническая поддержка Часовой пояс: GMT + 3
Страница 1 из 1
 
Перейти:  
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах
Вы не можете прикреплять файлы к сообщениям
Вы можете скачивать файлы, прикрепленные к сообщениям